सवाल क्या कोई आधुनिक ब्राउज़र है जो विंडोज 3.1 पर चलता है?


ठीक है, तो मुझे पता है कि आप क्या सोच रहे हैं: "आप पृथ्वी पर क्या कर रहे हैं अभी भी विंडोज 3.1 चल रहे हैं?"

स्थिति यहाँ है। कम्प्यूटर चलाना 3.1 जर्मनी में $ 150,000 बैंडसॉ के लिए भी नियंत्रक है, इसलिए निर्माण के सामने काफी पैसा खर्च किए बिना वास्तविक कंप्यूटर को अपग्रेड करने का कोई भी मौका किसी के लिए पतला नहीं है। समस्या यह है कि टाइमक्लॉक सॉफ्टवेयर एक वेब संचालित मंच पर है। नेटस्केप 4.0 साइट को सही तरीके से प्रदर्शित नहीं करता है और बटन को "लॉगिन" या "पंच" जैसे धक्का देता है।

जावा या फ्लैश जैसी चीजें necassary नहीं हैं। AFAIK, इसे सिर्फ HTML 4 और CSS का समर्थन करने की आवश्यकता है।

संपादित करें:

इसलिए मुझे लगता है कि इस्तेमाल होने वाले सॉफ़्टवेयर का खुलासा करना एक अच्छा विचार हो सकता है। आईटी इस गोररी रेगन का समय और उपस्थिति सॉफ्टवेयर। हमने कुछ अपडेट किए हैं क्योंकि हमने उन्हें पहले अधिग्रहित किया था। यह सेवा SQL सर्वर और आईआईएस संयोजन के माध्यम से होस्ट की जाती है।


222
2018-05-10 21:16


मूल


आप एक भौतिक घड़ी में देखना चाह सकते हैं। उनके पास बायोमेट्रिक उंगली / हाथ स्कैनर, स्वाइप कार्ड, प्रॉक्स कार्ड हैं। बहुत सारे घड़ियों वायरलेस हैं और समय और उपस्थिति सॉफ्टवेयर के साथ एकीकृत किया जा सकता है। कुछ में घंटी टाइमर, दरवाजा प्रवेश, संचय संतुलन, कार्यक्रम और समय प्रतिबंधों की क्षमता भी होती है। वेब पर पुराने सुरक्षा सॉफ़्टवेयर के साथ इस कंप्यूटर को खोलने से पहले ऐसा करना बेहतर होगा। - kobaltz
उपकरण को नियंत्रित करने के लिए कंप्यूटर का उपयोग किया जा रहा है, तो @Moab अपग्रेड करने का अच्छा विचार नहीं है। वह कंप्यूटर अकेला बेहतर छोड़ दिया गया है (और यदि संभव हो तो नेटवर्कवर्क नहीं किया गया है)। - Renan
वास्तविक सवाल यह है कि कोई भी आपके टाइम ट्रैकिंग प्लेटफ़ॉर्म में लॉग इन करने के लिए बैंडसॉ नियंत्रक का उपयोग क्यों करेगा। - Der Hochstapler
अगर प्रबंधन ने इसे "दुबला विनिर्माण" के नाम से पूछा है तो बस उन्हें बताएं कि इस काम को बनाने की लागत समय-सारिणी नौकरी करने के लिए एक और अधिक उपयुक्त मशीन का उपयोग करने की लागत को दूर करती है। एक नाखून हथौड़ा लगाने के लिए एक स्पैनर का उपयोग करने की कोशिश दुबला विनिर्माण नहीं है, यह है बेवकूफ विनिर्माण। - Mokubai♦
मैंने इसे वोट दिया क्योंकि या तो आपका जीवन बेकार है या आपने मुझे एक शानदार काम किया है। किसी भी तरह से, यह एक उथल-पुथल है। :) - tewha


जवाब:


इसे एक उत्तर के रूप में रखने के लिए खेद है, क्योंकि मैं आपको एक नहीं दे सकता, लेकिन एक टिप्पणी के लिए बहुत बड़ा लग रहा था।

सिफारिश करने वाले लोगों को जोड़ने के लिए नहीं ऐसा करने के लिए: Win 3.1 मशीन (इसे अन्य काम करने की इजाजत देकर) जितना अधिक उपयोगी होगा, उतना ही मशीन बस इतना उपयोगी है कि कुछ समझने के लिए पर्याप्त रूप से प्रतिस्थापित न हो।

Win3.1 एक नियंत्रक के रूप में एक भयानक ओएस है। इसके बारे में एक जीयूआई के साथ डॉस के रूप में सोचें, जो यही है। कोई प्रक्रिया अलगाव नहीं है इसलिए एक खराब ब्राउज़र विंडो (या कोई भी ऐप) नियंत्रक की मेमोरी स्पेस डरावनी कहर में स्मृति को स्कैम्बल कर सकता है। चूंकि आपके पास आधुनिक HTML / CSS / जावास्क्रिप्ट को देखने वाले पुराने ब्राउज़र हैं, इसलिए ब्राउज़र कीड़े के लिए बहुत सी संभावनाएं हैं और स्कैम्बल मेमोरी की बाधा अपेक्षाकृत बोल रही है, उच्च।

रीयलटाइम के लिए Win3.1 समर्थन में बहुत कुछ नहीं है। यहां तक ​​कि Win95 भी बेहतर था, हालांकि ज्यादा नहीं। इसका अर्थ यह है कि चूंकि ऐप्स सीपीयू को सहयोग और साझा करने का प्रयास करते हैं, इसलिए उन्हें जरूरी नहीं है, और कुछ ऐप या ब्राउज़र विंडो सभी CPU का उपयोग कर सकती हैं, जिससे नियंत्रक सॉफ़्टवेयर के लिए समय निकाल दिया जा सकता है। यह ठीक से खत्म नहीं हो सकता है। यह वास्तव में एक है पट्टी आरा

3.1 (गलती, डॉस वास्तव में) के लिए वायरस थे (संभवतः अभी भी हैं), इसलिए किसी भी नेटवर्क पर इसे खोलना आपको डराता है। किसी भी बुद्धिमान नेटवर्क इंजीनियर को फ़ायरवॉल की आवश्यकता होगी (यदि आप Win3.1 के लिए एक पा सकते हैं) और उस बिंदु पर आप मशीन को नीचे दबाएंगे। फिर, कई उत्तरों आईई 5 की सिफारिश करते हैं, जो इस बिंदु पर अप्राप्य है।

विन 3.1 लगभग 4 साल पहले समाप्त हुआ था (आश्चर्यजनक रूप से हाल ही में मेरी पुस्तक में)। 2010 में इंटरनेट एक्सप्लोरर 5.x का कोई भी आखिरी समर्थन था। मैं अपने बॉस को बता दूंगा यह एक बैंडसॉ से जुड़ा हुआ है और हम नियंत्रक सॉफ्टवेयर के साथ कोई समस्या नहीं चाहते हैं। यदि नियंत्रक-सॉफ्टवेयर लोग सभी स्मार्ट थे, तो उनके पास एक क्लॉज होगा जो किसी भी अन्य सॉफ़्टवेयर को नियंत्रक बॉक्स पर अनुमति नहीं देगा, या आप उनसे कुछ समर्थन रद्द कर देंगे।

यदि आपको वास्तव में नियंत्रक के करीब कुछ चाहिए, तो मैं वाईफाई + सस्ता टैबलेट / प्रयुक्त आइपॉड टच कहूंगा, लेकिन मैं स्पष्ट रूप से कहूंगा कि आपको अपने वाईफाई नेटवर्क को सुरक्षित करने की आवश्यकता है।


210
2018-05-10 22:26



उत्कृष्ट अंक, लेकिन यह भी ध्यान रखें कि मौजूदा कंप्यूटर को औद्योगिक वातावरण का सामना करने के लिए बनाया गया हो सकता है, जबकि एक आम उपभोक्ता-ग्रेड टैबलेट / आईपॉड लंबे समय तक नहीं टिक सकता है अगर इसे धुएं, धूल आदि का सामना करने के लिए नहीं बनाया गया है। । - rob
@rob सच है, लेकिन फिर भी मैं एक गैर-सुरक्षात्मक ओएस पर औद्योगिक उपकरण से कनेक्ट एक अप्रत्याशित आईई चलाने पर कुछ तीसरे विकल्प की सिफारिश करता हूं। - Rich Homolka
रीयलटाइम के लिए Win3.1 समर्थन में बहुत कुछ नहीं है। - इस तथ्य को छोड़कर कि कोई भी एप्लिकेशन सीपीयू को तब तक जब्त कर सकता है जब तक वह चाहें, इसे ओएस या किसी अन्य एप्लिकेशन को नहीं दे रहा है। इसमें बैंडस नियंत्रक ऐप शामिल है। - Random832
यह यह है। इस तरह के एक महत्वपूर्ण Win 3.1 बॉक्स में ब्राउज़र को रखने का विचार सिर्फ दिमागी-बुरी तरह खराब है। मैं बस जाग गया, इसलिए यह निश्चित रूप से सबसे बेवकूफ बात है जो मैंने आज सुना है :-)। यदि आवश्यक हो तो "लिनक्स और वाइन" समाधान का उल्लेख मेरे लिए दिलचस्प लगता है यह करना है एक ही कंप्यूटर पर एक ब्राउज़र है जो बैंडसॉ (अभी भी बेवकूफ है, लेकिन बहुत अधिक सुरक्षित है, और यह एक और समस्या का ख्याल रखेगा: Win 3.1 कंप्यूटर मर्जी कभी तोड़ो अपग्रेड करने के लिए तैयार रहें)। लेकिन जोर से रोने के लिए: बस एक और प्राप्त करें पृथक ऐसा करने के लिए कंप्यूटर या डिवाइस। - Daniel Andersson
Win3.1 किसी भी वास्तविक समय की क्षमताओं को प्रदान नहीं कर सकता है, लेकिन यह कस्टम इंटरप्ट हैंडलर इंस्टॉल करके, सॉफ्टवेयर के रास्ते में भी नहीं मिलता है। यह उन कुछ चीजों में से एक है जो 16-बिट सॉफ़्टवेयर को वास्तव में Win9x और XP पर काम नहीं करते हैं, इसलिए मुझे पूरा भरोसा है कि यह क्या हो रहा है। इसलिए कंप्यूटर को अपग्रेड करना एक गैर-स्टार्टर है। असली सवाल यह है कि अगर कोई कॉन्फ़िगरेशन बदल जाता है (नया सॉफ़्टवेयर इत्यादि जोड़ता है) तो किसी को बैंडैंड नियंत्रक काम करना जारी रखने की अपेक्षा करता है। - Ben Voigt


ओपेरा 3.62 एक आधुनिक ब्राउज़र का सबसे अच्छा मैच हो सकता है, जो अभी भी विंडोज 3.1 जैसे पुराने सिस्टम पर चलता है (जिसमें टीसीपी / आईपी के लिए कोई मूल समर्थन नहीं है)। एचटीएमएल और सीएसएस समर्थन इस ब्राउज़र की उम्र के लिए काफी अच्छा है, लेकिन बहुत ज्यादा उम्मीद नहीं है। यह भी ध्यान रखें कि डोम के हेरफेर के माध्यम से वेबसाइटों में गतिशील परिवर्तनों के लिए ओपेरा 3.62 का कोई समर्थन नहीं है, जो आधुनिक जावास्क्रिप्ट संचालित वेब अनुप्रयोगों को अनुपयोगी बनाता है।

मैं टाइम घड़ी सॉफ्टवेयर के लिए एक और कंप्यूटर का उपयोग करने का सुझाव दूंगा। आपकी समस्या के अलावा ऐसी पुरानी प्रणाली केवल नेटवर्क से अलग होनी चाहिए, क्योंकि ज्ञात भेद्यताएं ज्ञात हैं। दूसरी तरफ, कोई तर्क दे सकता है कि ऐसे पुराने प्लेटफॉर्म पर मैलवेयर चलने वाले वर्चुअल नेटवर्क का कोई नेटवर्क नहीं है। वैसे भी मैं इस तरह की एक विशेष मशीन का उपयोग करके जोखिम को नियंत्रित करने के अलावा कुछ भी करने का जोखिम नहीं उठाऊंगा। यदि आप किसी अन्य कंप्यूटर पर किए गए कार्यों के लिए इसका उपयोग करने के कारण टूट जाते हैं तो आप क्या करेंगे?


107
2018-05-10 21:42



यह सबसे अच्छा समाधान की तरह लगता है। बस एक ही क्षेत्र में दो कंप्यूटर रखें। Windows 3.1 को इंटरनेट तक पहुंचने की अनुमति देने की समस्या हल करता है, और एक असुरक्षित ब्राउज़र के उपयोग को हल करता है (3.1 पर चलने वाली कुछ भी असुरक्षित होगी)। - Ramhound
एक वास्तविक उत्तर के लिए धन्यवाद। एक बार चीजें थोड़ी धीमी हो जाती हैं, तो मैं इसे एक शॉट दूंगा! अगर सब ठीक दिखता है, तो मैं इसे उत्तर में रखूंगा। - Chad Harrison
मैं सोच रहा था कि समय-सारणी को जर्नलिंग या बिलिंग कारणों (आंखों के संचालन के लिए) के लिए एक ही कंप्यूटर पर होना आवश्यक था, या यदि यह सुविधा के समान था। यदि उपकरण के लिए इसकी आवश्यकता नहीं है, तो सुविधा को हार्डवेयर के एक अलग टुकड़े पर ले जाएं। - horatio
@horatio आप बिलिंग कारणों के बारे में सही हैं। टाइम घड़ी सॉफ्टवेयर में परियोजना प्रबंधन सुविधाओं का बहुत कुछ है जो आपको विशिष्ट परियोजनाओं के लिए समय और सामग्री आवंटित करने की अनुमति देता है जो वास्तविक लागतों को ट्रैक करने में मदद करता है। ऐसा लगता है कि देखा गया एक और "डिवाइस" की आवश्यकता होगी। - Chad Harrison
0: इस सवाल का एकमात्र सही जवाब है, इस सन्दर्भ में, है न करें। यह उत्तर निश्चित रूप से किसी अन्य संदर्भ में ठीक हो सकता है। - o0'.


एर ... क्या आप वास्तव में एक $ 150,000 बैंडस को नियंत्रित करने वाले पत्थर युग से कंप्यूटर को दूसरा कार्य देना चाहते हैं ..?

अभियोगी के लिए न्यायाधीश: हमें बताएं कि आपने अपनी भुजा कैसे खो दी।
वादी: ठीक है, बॉब उस दिन काम करने में देर हो चुकी थी और जब मैं बैंड का उपयोग कर रहा था तब घड़ी को पेंच करने की कोशिश की।
अभियोजक अभियोजक (बॉब): क्या आप जानते थे कि बैंड घड़ी हमेशा बंद हो जाती है जबकि टाइम घड़ी वेबसाइट खुलती है?
प्रतिवादी: निश्चित रूप से, हर कोई जानता है कि। हम बस उस व्यक्ति को क्लॉक इन या क्लॉक आउट बटन पर क्लिक करने की प्रतीक्षा करेंगे और फिर देखा जाएगा कि वापस आ जाएगा!
Plantiff: मुझे नहीं पता था कि बॉब देर हो चुकी थी! जब कोई हिस्सा फंस जाता है तो देखा जाता है। मुझे यह कैसे पता चल गया था कि जब मैं वहां भाग ले रहा था तो अचानक अचानक बैक अप शुरू हो जाएगा ..?


76
2018-05-12 16:38



मुझे लगता है कि हर समय का सर्वश्रेष्ठ एसयू जवाब! - gregg


  1. वीएनसी अभी भी विंडोज 3.1 के लिए काम करता है। वीएनसी स्थापित करें और एक अधिक सक्षम मशीन से कनेक्शन खोलें, विंडोज 3.1 मशीन तक पहुंचने वाले शेयरों के साथ (या आईआईएस के साथ एक एफ़टीपी सर्वर चला सकते हैं)।

  2. 3.1 मशीन पर XWindows क्लाइंट चलाएं, और XServer चलाने वाली मशीन से कनेक्ट करें। फिर आप टर्मिनल विंडो में आधुनिक ब्राउज़र चला सकते हैं।

क्लासिक तकनीक रॉक करने के लिए रास्ता। विंडोज 3.1 नए ओएस / 360 मेनफ्रेम के रूप में कंपनी को बदलने से डरता है। :)


39
2018-05-12 19:44



मेरा मतलब है, वीएनसी मेरे वाईआई पर चलता है, यह हर जगह काम करता है। - ZJR
यह सबसे सुरक्षित और भरोसेमंद भविष्यरोधी समाधान है - Joeri Sebrechts


तकनीकी रूप से, आप शीर्ष पर चलाने के लिए एक और आधुनिक 32-बिट ब्राउज़र प्राप्त करने में सक्षम हो सकते हैं Win32s (जो आपको 16-बिट विंडोज़ के लिए 32-बिट कार्यक्षमता का सबसेट देता है)। यदि आप इसे आजमा देना चाहते हैं, तो मैं ओपेरा, मोज़िला / फ़ायरफ़ॉक्स इत्यादि के "पोर्टेबल" संस्करणों से शुरू करूंगा। (मैंने इसे दूसरे दिन एक टिप्पणी में भी उल्लेख किया, लेकिन इसे हटा दिया क्योंकि मुझे नहीं लगता था कि यह सलाह दी गई थी। )

उस ने कहा, आप अपने निर्णय पर पुनर्विचार करना चाहेंगे कि एक नई मशीन पर सॉफ्टवेयर चलाने की कोशिश न करें। अमीर के रूप में बताया, आपके बैंडस नियंत्रक पीसी पर एक वेब ब्राउज़र चलाने के कई कारण हैं।

हालांकि, किसी बिंदु पर इस पीसी के साथ कुछ बुरा होगा, और उस समय आप बहुत सारा पैसा खोने जा रहे हैं यदि आपके पास अच्छी तरह से परीक्षण की गई बैकअप योजना नहीं है। मुझे दुबला विनिर्माण के बारे में बहुत कुछ पता नहीं है, लेकिन मुझे पता है कि जब कोई महत्वपूर्ण प्रणाली किसी आकस्मिक योजना के साथ नहीं जाती है, तो इसका संचालन पर तत्काल और प्रत्यक्ष प्रभाव पड़ता है।

ऐसा कुछ जो आपको अभी बहुत अधिक खर्च नहीं करेगा (समय से अलग) विंडोज 3.1 इंस्टॉलेशन को वीएम या एमुलेटर जैसे डॉसबॉक्स में कॉपी करने का प्रयास करेगा, या यहां तक ​​कि सीधे विंडोज के एक नए संस्करण पर सॉफ्टवेयर चलाने की कोशिश करेगा। कई कार्यक्रम पहले प्रयास पर नहीं चलेंगे, लेकिन सही संगतता विकल्पों के साथ चलाने के लिए बनाया जा सकता है। मैं कई साल पहले सुखद आश्चर्यचकित था जब मैं बीमा कंपनी के स्वामित्व वाले डॉस ऐप को कमांड या cmd.exe पर अतिरिक्त ध्वज की आपूर्ति करने के अलावा कुछ भी नहीं कर विंडोज 2000 और एक्सपी पर ठीक काम करने में सक्षम था। (ध्यान दें कि command.com केवल विंडोज 7 के 32-बिट संस्करणों पर उपलब्ध है।) भले ही आपको निर्माता से कोई समर्थन न मिल जाए, फिर भी आप इसे स्वयं समझ सकते हैं या स्थानीय स्वतंत्र कंप्यूटर शॉप ढूंढ सकते हैं या तकनीक जो चुनौती तक है।

किसी भी प्रसंस्करण समय पर भी विचार करें जिसे आप वर्तमान में बर्बाद कर रहे हैं। हो सकता है कि आपके बैंडसॉ नियंत्रक के लिए फ़ाइलों को खोलना और सहेजना तात्कालिक है, लेकिन अगर आप सभी "लोडिंग ..." स्क्रीन को छोटा करके या हटाकर दिन में कम से कम कई मिनट पुनर्प्राप्त कर सकते हैं तो मुझे आश्चर्य नहीं होगा। मेरे उपाख्यानों में बीमा एजेंट उत्साही थे, क्योंकि नई मशीनों में माइग्रेट करने का स्पष्ट दुष्प्रभाव यह था कि सब कुछ तेजी से चल रहा था, इसलिए वे स्क्रीन आने के लिए इंतजार नहीं कर रहे थे।

यदि एक परीक्षण पीसी पर एक और अधिक आधुनिक ओएस चल रहा है, तो आप इसे स्थायी प्रतिस्थापन के रूप में सेट कर सकते हैं और पुराने पीसी को बैकअप के रूप में रख सकते हैं। (यदि आप नियमित रूप से डेस्कटॉप मशीन को अपने पर्यावरण में बहुत लंबे समय तक जीवित रहने की संभावना नहीं रखते हैं, तो आपको बहुत सस्ते के लिए 5- या 10-वर्षीय औद्योगिक पीसी लेने में सक्षम होना चाहिए।) आप अभी भी दौड़ना नहीं चाहते हैं इसके लिए एक वेब ब्राउज़र वास्तविक समय प्रदर्शन, सुरक्षा, और अपटाइम कारणों से, लेकिन कम से कम आपको उस दुर्भाग्यपूर्ण दिन के बारे में चिंता करने की ज़रूरत नहीं होगी जब पीसी टूट जाए।


24
2018-05-10 23:23



एक वीएम या डॉसबॉक्स के अलावा, वहाँ है वाइन लिनक्स पर - detly
नियंत्रक लगभग निश्चित रूप से एक वास्तविक समय आवेदन है। इसका मतलब है कि इसे हर 100 एमएस या उससे भी ज्यादा के लिए चलाने की जरूरत है। एक एमुलेटर में, इसकी गारंटी नहीं है। यदि आप किसी अन्य विंडो में कोई एप्लिकेशन (ब्राउज़र की तरह) शुरू करते हैं, तो यह वीएम या एम्यूलेटर से CPU समय लेगा। लिनक्स के रीयल-टाइम संस्करण हैं, लेकिन वीएम को यह काम करने के लिए कस्टम प्रोग्रामिंग की आवश्यकता होगी। - Kevin Vermeer
@ केविन वर्मीर सच - मैंने स्पष्ट किया है कि वास्तविक समय प्रदर्शन मेजबान ओएस पर वेब ब्राउज़र चलाने के कारणों में से एक है। - rob


यदि आपके वेब-आधारित टाइमक्लॉक सॉफ़्टवेयर में 4-5 विकल्पों के साथ केवल 2 या 3 मेनू हैं, तो मुझे लगता है कि विंडोज 3.1 एप्लिकेशन विकसित करने के लिए एक सस्ता प्रोग्रामर पूछना जो वेबसाइट पर डेटा लाता है और उचित डेटा भेजता है, जाने का सबसे आसान तरीका होगा ।

संभावना है कि आपके कम लागत वाले प्रोग्रामर के पास पहले से ही विंडोज 3.1 3.1 है जो अपने प्राथमिक ओएस के रूप में 486 डीएक्स 33 पर है।

यह (लगभग) मजाक नहीं है, लेकिन सबसे सस्ता और तेज़ समाधान है।


15
2018-05-11 02:09



और दूसरा समाधान @rob का समाधान है: पीसी को अपने पीसी को बेहतर ओएस के साथ बदलने के लिए, लेकिन उसी आई / ओ (सीरियल पोर्ट, समांतर बंदरगाह और अन्य) के साथ और मूल डेटा / कंपनी सॉफ्टवेयर के साथ। - leye0
मैं शर्त लगाता हूं कि "सस्ता डेवलपर" किसी वेबसाइट से डेटा लाने के लिए टीसीपी / आईपी समर्थन के बिना एक मशीन प्रोग्राम नहीं कर सकता है। - ONOZ
या एक सस्ते प्रॉक्सी वेबसाइट / सेवा बनाने के लिए जो नेटस्केप 4.0 के लिए काम करता है - Ivarpoiss
@ONOZ: 3.1 में टीसीपी / आईपी समर्थन है। - grawity
निश्चित रूप से दो पीसी सस्ता है। - leonigmig


मुझे लगता है कि एक समझदार समाधान होगा:

  • कुछ लंबे समय तक समर्थन लिनक्स वितरण (सेंटोस / आरएचईएल / उबंटू एलटीएस) के साथ आधुनिक कंप्यूटर (कम से कम 2 प्रोसेसर कोर के साथ) सेट करें;

  • वहां एक वर्चुअल मशीन सेट करें - इसे सेटअप करें ताकि यह केवल आपके बैंडसॉ से कनेक्ट हो सके (मुझे नहीं पता कि यह कैसे जुड़ा हुआ है - मुझे लगता है उदाहरण के लिए सीरियल कनेक्शन के साथ -serial /dev/ttyS0  का विकल्प qemu मदद करनी चाहिए, -net none विकल्प नेटवर्क अक्षम करेगा);

  • इस वर्चुअल मशीन पर विंडोज 3.1 स्थापित करें और वहां बैंडसॉ सॉफ्टवेयर चलाएं।

आपके पास टाइमक्लॉक सॉफ़्टवेयर और असुरक्षित के लिए आधुनिक सुरक्षित सिस्टम और ब्राउज़र होगा लेकिन बैंड सिस्टम के लिए इंटरनेट सिस्टम से अलग होगा।

यह वर्तमान सेटअप छोड़ने से भी बेहतर है - 15 साल का कंप्यूटर जल्द से जल्द तोड़ देगा और आपके पास इसे बदलने का कोई साधन नहीं होगा। वर्चुअल मशीन को किसी अन्य कंप्यूटर पर ले जाना लगभग डिस्क छवि फ़ाइल को स्थानांतरित करने जितना सरल है।


13
2018-05-11 10:35



काम नहीं करेगा - आप बैंडस नियंत्रण के समय को बुरी तरह खराब कर देंगे। मौजूदा सॉफ्टवेयर के लिए Win3.1 आवश्यकता के लिए सबसे संभावित कारण यह है कि यह वास्तविक समय के संचालन के लिए अपने स्वयं के इंटरप्ट हैंडलर स्थापित करता है। आधुनिक ओएस पर यह संभव नहीं है जो अनुप्रयोगों को अप्रतिबंधित करते हैं, और जब एक वीएम इसे अनुकरण कर सकता है, तो अंतराल विलंबता अधिक होगी और अधिक अप्रत्याशित होगी। - Ben Voigt
आधुनिक लिनक्स पर आप रीयल-टाइम शेड्यूलिंग के लिए वर्चुअल मशीन प्रक्रिया सेट कर सकते हैं chrt --fifo qemu ...। इसके अलावा आधुनिक प्रणाली 15 वर्षीय की तुलना में सैकड़ों गुना तेज होगी। मुझे नहीं लगता कि बहुत धीमी प्रतिक्रिया के समय में समस्या होगी। - Tometzky
इंटरप्ट हैंडलर वास्तविक समय निर्धारित प्रक्रियाओं की तुलना में बहुत तेज हैं। इसके अलावा, बहुत तेज प्रतिक्रिया एक समस्या जितनी बड़ी हो उतनी धीमी हो सकती है। वीएम का उपयोग करते समय प्रतिक्रिया विलंबता की अप्रत्याशितता से बचने के लिए मुझे कोई रास्ता नहीं दिखता है। - Ben Voigt


मुझे लगता है कि इस पर एक माइक्रोसॉफ्ट उत्पाद के साथ जाने के लिए आपकी सबसे अच्छी शर्त है। लगता है कि अंतिम संगत इंटरनेट एक्सप्लोरर रिलीज प्रतीत होता है 5.01

OldApps दिए गए प्लेटफ़ॉर्म के लिए नवीनतम रिलीज़ किए गए संस्करणों की एक वास्तविक अच्छी सूची है। हालांकि, उस तालिका के विपरीत, 5.01 विंडोज 3.1 के लिए भी सूचीबद्ध है।

Operating System        Latest Software Version
Windows 3.1             Internet Explorer 3.01 (Windows 3.1)
Windows 95              Internet Explorer 5.0
Windows 98              Internet Explorer 6.0 (Setup Only)
Windows 2000            Internet Explorer 6.0 (Setup Only)
Windows ME              Internet Explorer 6.0 (Setup Only)
Windows Server 2003 x64 Internet Explorer 7.0 (x64)
Windows Server 2003     Internet Explorer 7.0 (Final)
Windows XP x64          Internet Explorer 8.0 (XP x64)
Windows XP              Internet Explorer 8.0 (XP)
Windows Vista x64       Internet Explorer 9.0 (Vista)
Windows Vista           Internet Explorer 9.0 (Vista x64)
Windows 7 x64           Internet Explorer 9.0 (7 x64)
Windows 7               Internet Explorer 9.0 (7)

6
2018-05-10 21:42



यह पृष्ठ विंडोज 3.1 के लिए आईई 5.1 दिखाता है ....oldapps.com/internet_explorer.php - Moab
@ मोआब: तुम सही हो। अजीब। मैंने जवाब में एक नोट जोड़ा। - Der Hochstapler
यह जानकारी गलत है, क्योंकि विंडोज 3.1x के लिए एक इंटरनेट एक्सप्लोरर 5.01 था। हालांकि मैं मानता हूं कि इंटरनेट एक्सप्लोरर 5.01 नेटस्केप 4 की तुलना में बेहतर विकल्प होगा, अगर मुझे सही याद है तो ओपेरा 3.62 में अभी भी बेहतर सीएसएस और एचटीएमएल समर्थन होगा। - Gurken Papst
@GurkenPapst: मेरा विचार था कि माइक्रोसॉफ्ट उत्पाद का उपयोग करना सबसे अच्छा हो सकता है क्योंकि कंप्यूटर का मुख्य रूप से किस काम के लिए उपयोग किया जाता है। मुझे अभी भी पूरी बात बल्कि संदिग्ध लगता है। - Der Hochstapler