सवाल मैं लिनक्स में Google क्रोम पर जावा समर्थन कैसे प्राप्त करूं?


जावा समर्थन के साथ लिनक्स Google क्रोम चलाने का कोई तरीका है?


85


मूल


मॉडरेटर नोट: क्रोम 35 के बाद से मैंने उन उत्तरों को हटा दिया है जो अब अप्रचलित हैं एनपीएपीआई समर्थन गिरा दिया है और यहां पोस्ट की गई विधियां सब काम नहीं करेंगे। यदि लोग अभी भी सॉफ्टवेयर के पुराने स्थिर संस्करणों को चलाने के लिए चाहते हैं, तो हम आम तौर पर पुराने उत्तरों को नहीं हटा रहे हैं, लेकिन क्रोम के साथ, यह वास्तव में व्यवहार्य और व्यावहारिक नहीं है। जवाब देने के लिए तत्पर हैं जो नवीनतम संस्करण पर विचार करते हैं, इसलिए संयुक्त प्रयासों को प्रोत्साहित करने के लिए इस समुदाय विकी को बनाते हैं। - slhck
उबंटू पूछे जाने पर संबंधित प्रश्न: askubuntu.com/questions/470594/... - slhck
अफैक और इसके अनुसार भी productforums.google.com/forum/#!topic/chrome/qPiZkcLwFFk लिनक्स रिलीज के लिए हाल ही के Google क्रोम पर जावा का समर्थन करने का कोई तरीका नहीं है। तो फ़ायरफ़ॉक्स पर स्विच करें या उपयोग करें - carefuly - क्रोम का एक पुराना संस्करण। - lmedinas
पर जानकारी java.com/en/download/faq/chrome.xml थोड़ा उलझन में है, लेकिन ऐसा लगता है कि लिनक्स में जावा चलाने के लिए आपको 64-बिट क्रोम और 64-बिट जावा 7 की आवश्यकता है। (यह दावा करता है कि क्रोम में 64-बिट लिनक्स संस्करण नहीं है, लेकिन वह झूठा है)। - trlkly
एक और चीज जिसे मैंने परीक्षण नहीं किया है, इसलिए मैं जवाब के रूप में उपयोग नहीं करूंगा: यदि आप शराब में क्रोम चलाते हैं तो क्या होता है? क्या विंडोज जावा 7 प्लगइन वहां काम करता है? यदि हां, तो ऐसे प्लगइन प्राप्त करने के लिए प्रोजेक्ट हैं जो विंडोज़ में लिनक्स ब्राउज़र में चलाने के लिए काम करते हैं। उदाहरण के लिए नेटफ्लिक्स काम करने के लिए एक का उपयोग किया जाता है। (यह मुख्य रूप से लोगों को उत्तर खोजने में मदद करने के लिए एक सुझाव है।) - trlkly


जवाब:


एक लड़का (माइकल मुलर) है जिसने एनपीएपीआई (इसलिए आईसीएडीटीए काम करेगा) के समर्थन को सक्षम करने के लिए कुछ पैच लिखे हैं।

यह कुछ हद तक एक कामकाज है। लेकिन काम करने की उम्मीद है। (असल में मैंने परीक्षण नहीं किया है)

वर्तमान में निर्माण संस्करण 36 है।

यदि आप ArchLinux का उपयोग करते हैं तो आप इसे AUR से बना और इंस्टॉल कर सकते हैं। क्रोमियम-NPAPI

यदि नहीं, तो आप देख सकते हैं PKGBUILD निर्माण प्रक्रिया।


1





लिनक्स में icedtea स्थापित करने का प्रयास करें। यह एक जादू की तरह काम करता है।

उबंटू के लिए

apt-get install icedtea


-3



क्या यह वास्तव में क्रोम 35 या नए पर काम करता है? - Journeyman Geek♦
यह काम नहीं करता है। रेफरी: superuser.com/questions/44827/... - Sathya♦